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1 General characteristics of the
SurfaceView software package

The SurfaceView’ is intended for processing, visualization and analysis of SPM-data received
with scanning probe microscopes and saved in files of a special format. The files with extension
*.SPM (*.PPM) are initial data for the SurfaceView.

The SurfaceView works under operating system Windows 98/Me/2000/XP and features user
interface characteristic for this OS. The program includes an executable file SurfaceView.EXE and
additional plug-in files. After the start, main window of the program will appear on the desktop (Fig.
1.1). Main window contains a menu bar, tool bar, status bar and panel of settings.

Menu bar

Tool bar

Status bar

Panel of settings2D visualization windows

Fig.1.1. Main window of SurfaceView program.

Commands available in the program menu bar are shown in Fig. 1.2.
Tool bar provides fast access to the most frequently used commands. Functions of the buttons

are described in Fig. 1.3.
Status bar shows the name of the file in active visualization window (selector File) and

corresponding operation performed with data shown in active window (selector Step). These selectors
can be used to switch to the images listed in them. Buttons Close serve for deleting selected file or
step from the SurfaceView memory. Note that closing visualization window without pressing the
button Close leaves corresponding data sets in the program buffer. Choosing then corresponding file
or step in the selectors will bring the images back in the desktop.
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File View Process Functions Window Help
Open View 2D Normalize Contact deformation Tile About
Save View 3D Arithmetic Eliminate phase artifacts Cascade
Data link Profile Cut Filters > Pulse Filter Arrange all
Options Height distribution Flattening > Line on X direction Medium Filter
Exit Angle analysis Line on Y direction Fractal dimension

Surface info Plane Noise > Tip Estimate
View layout Parabola on X Erosion
Zoom > 100% Parabola on Y Dilation

200% Paraboloid Export to text format
400% Surface tomography
800% DFS analysis

Nonlinearity

Fig. 1.2. Menu commands of SurfaceView program.
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Fig. 1.3. Functions of buttons in SurfaceView tool bar.

Panel of settings will be described below in section View layout.

2 Menu File

2.1 SPM data file opening

The work with the program starts with opening an SPM-data file. Default file format is that one
produced in AFM control software SurfaceScan, files created by other SPM software can be opened
using additional filters. To open an SPM data file, choose menu command File > Open or press button

 in the tool bar. After selecting necessary file in a file open dialog window, additional dialog Link
data (Fig. 2.1) will propose to load all the data sets contained in the SPM-data file or to deactivate
some of the data types. Note that all the data sets present in a file are obtained simultaneously with
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measuring the sample topography and may vary depending on the operation mode of the SPM
produced these data.

Button Add link allows manual linking of the data for processing them together with the loaded
file. These additional data must be taken simultaneously with the loaded image therefore user should
watch the validity of such addition of links.

Fig. 2.1. Dialog window Link data for selecting SPM data sets to be processed in the SurfaceView after the file opening.

SurfaceView proposes also an option to load bitmap images (for example, SEM micrographs)
and convert their grayscale to height values. That allows to simulate a 3D image of simple 2D data
and process then it with available functions. So, choosing a bmp-file for opening in the file open
dialog, window Import bitmap file (Fig. 2.2) will propose to mark the meaningful area in the image
that will be then converted in 3D data set. This operation is done with mouse; the selected area is
marked with red square. After that, you need to assign scales for X, Y and Z axes (in nm).

Fig. 2.2. Dialog window for setting parameters at Import bitmap file.

Scale values can be calculated right in the window based on known distances along X and Y
axes. For that purpose, press button Calibrate and using mouse drag a line (Fig. 2.3) corresponding to
known distance in the image. Absolute value (in nm) of length for drawn yellow line should be entered
in pane Distance in the dialog window (in Fig. 2.3 it is 19000 nm). To return to the selection of
meaningful area, release button Calibrate. Note that SEM micrographs usually contain special scale
that can be used for defining the scale parameters at the bitmap image conversion.



Microtestmachines Co.

7

Fig. 2.3. Defining scales based on known distance.

After the file loading, 2D visualization window (Fig. 2.4) appears on the desktop rendering the
loaded SPM data as an image. The opened file is registered in selector File in the program status bar
and if you opened more than one files, the selector provides fast access to the necessary file to bring
it up on the program desktop (makes it active).

Fig. 2.4. 2D visualization window image showing surface topography measured with AFM.
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2.2 Data saving

Command File > Save in program menu or button  in the tool bar allows to save the SPM
data from active 2D visualization window in file on hard disk. The data from the active window will be
saved as they are, i.e. if the window contained processed data, resultant file will contain processed
data as well. Additionally, all data sets linked to current image by function Data Link will be saved in
the same file.

Command File > Save in program menu or button  in the tool bar relate to all types of data
in active window. Therefore, depending on the window type, you can save data in files of different
formats. For example, AFM images can be saved in *.SPM file of special format or bitmap file on disk.
Profile curves can be saved in text file or bitmap file. Text information from info window can be saved
in text file.

2.3 Data Link

Command File > Data Link brings up dialog window Link data (Fig. 2.1) for loading SPM data
from file on disk and their linking to the active SPM image (data set). Data set is a collection of SPM
images relating to one scan and acquired simultaneously at the surface measurement (e.g.
topography and phase shift image, topography and lateral force map). This command is used if SPM
data taken at the same scan were saved in different files. SPM data files with multiple field structure
need no separate linking procedure as all data from the set are loaded automatically.

Button Add link activates dialog window for loading and linking data from other file. After
choosing the file to load, you will need to select type of loaded data marking necessary option with
tick. After linking additional data, command File > Data Link allows to switch the loaded data sets on
and off for visualization.

2.4 Panel of options settings

Command File > Options brings up panel for setting global options of the SurfaceView program
(Fig. 2.5).

Fig. 2.5. Panel of options setting.

You can specify whether to normalize data automatically at the file opening (Auto normalize),
use the same window after the image processing (Reuse window after processing), us multilevel undo
function (Undo), save images automatically after each step (Autosave options). Options Data directory
and Temp directory allow to specify, correspondingly, default folder with SPM data and folder where
temporary files will be kept at the program running.
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2.5 Exit command

Command File > Exit closes current session of the SurfaceView program.

3 Menu View

3.1 2D visualization window (View 2D)

Menu command View > View 2D or button  in the tool bar serves to bring visualization
window of active image with new data set (if they are present in the file). A list of data sets contained

in current SPM data file is available at pressing selector arrow  near the button in tool bar. The
same list of data sets is available in the context menu (Fig. 3.1) brought up by right mouse click
within SPM image area of 2D visualization window.

Fig. 3.1. Context menu of 2D visualization window.

The image sizes along axes X and Y in 2D window are shown in microns. Grayscale at right side
of the image shows height distribution of the image colors (from the lowest to the highest ones).
Matrix size (in points) of the shown SPM image is displayed below the image.

Type of data set shown in the visualization window, file name and the current processing step
number are displayed in the window title bar (Fig. 3.1).
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3.2 3D visualization window (View 3D)

Menu command View > View 3D or button  in the tool bar bring up a visualization window
where current SPM image is rendered in 3D view (Fig. 3.2). Note that this function is intended for
topography data only and running this command for contrast images in current data set,
corresponding topography data will be displayed in 3D visualization window.

Fig. 3.2. Visualization window with 3D view of the SPM image.

Information present in upper left corner of the window shows size of the image (upper line),
amplitude of heights in the image in nm (middle line) and roughness statistics (in nm) of the displayed
surface area (lower line).

3D visualization window can be resized with mouse if necessary. Using mouse, you can also to
rotate the displayed image and zoom in or off it. Mouse movement at holding left mouse button
pressed within the visualization area makes image rotation. Mouse vertical movement at holding right
mouse button pressed within the visualization area allows image zooming.

3.3 Profile visualization window (Profile)

Menu command View > Profile or button  in the tool bar start profile measuring function
and bring up corresponding window for profile visualization (Fig. 3.3). Using the function, you can
build a cross section profile of the topography image along the necessary straight line in any place of
the image. After the command selection, a line across the current topography image appears in 2D
visualization window and corresponding profile line is displayed in View Profile window.

If necessary, position and length of the cross section line can be changed in three ways:
1. Drag start or end node of the cross section line with left mouse button pressed in 2D

visualization window (visual way).
2. Press left mouse button in any point in the image and move mouse with the held button in

2D visualization window (visual way). The end of the line will be set at the mouse button
release.

3. Enter the cross section line coordinates manually in additional panel Select coordinates in
upper right corner of the profile visualization window (parametric way).
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All changes of the cross section line position and correspondingly changes of current profile will
be simultaneously displayed in the profile visualization window.

Fig. 3.3. Visualization windows for 2D view (left) and profile (right).

The profile visualization window is divided into two areas: profile plot area in the upper part and
control area in lower part of the window.

Additional panel Select coordinates in plot area serves for showing and parametrical changing
coordinates of cross section line. The additional panel can be reduced by button  in upper right
corner.

Info line at the plot area bottom shows
• coordinates of start and end nodes of the cross section line,
• type of data where the profile is picked up,
• X and Z coordinates of marked point in the profile (if one marker is enabled) or difference

on X (length) and Z (height) between two marked points in the profile (if two markers are
enabled),

• Z coordinate of the midline.
Control area of the window manages plotting of one or two profiles corresponding to the same

cross section line in different data types (correspondingly, sections ‘1:’ and ‘2:’). However, cross
section line will be depicted and enabled for visual (on-line) changes in 2D visualization window of the
topography image. You can assign type of plotted profile and its color in corresponding selectors of
the sections ‘1’ and ‘2’. On-line processing function for the profiles provide:

• Show middle line – shows/hides middle line of current profile line;
• Normalize – current profile normalization (shifts vertical zero point to the lowest point of the

profile);
• Eliminate tilt – eliminates tilt of the profile line making middle line horizontal.
Selector One marker / Two markers switches mode of operation with one or two markers in the

plot area. When one marker mode is enabled, you can measure absolute values of the profile points
length and height coordinates. When two markers mode is selected, relative length and height of one
point against other is measured and showed in the info line. Option Show on 2D switch on and off
displaying of the marker position on cross section line in 2D visualization window (topography image).

Button Bookmark inserts in current active marker position a special label (a bookmark – yellow
rectangle with red anchor line) where absolute X and Z coordinates of current point are displayed. The
bookmarks can be dragged with left mouse button within the plot area. To delete the bookmark, click
right mouse button on it.

Button Info brings up information about current profile line: image filename and the cross
section line coordinates (in points), number of points in the line, maximum height, nominal length of
the profile, actual length of the profile, mean value of the heights, roughness parameters Ra (mean
deviation of profile line) and Rq (mean root square deviation of profile line), skewness (Rsk), kurtosis
(Rku).
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If necessary, plotting data of the profile line can be saved in a text file for its analysis or
processing with other software (menu command File > Save or button  in the tool bar). Statistical
information about the profile will be also saved in the file.

3.4 Height distribution analysis

Command View > Height distribution or button  in the tool bar opens panel for height
distribution analysis (Fig. 3.4).

Fig. 3.4. Panel of height distribution analysis.

Panel of height distribution analysis has two plot areas in upper part where are displayed a
height distribution histogram (left diagram) and bearing ration curve (right diagram). Height
distribution histogram shows a share of the surface points located at given height relative total
number of surface points (in per cent). Vertical axis of the histogram corresponds to heights in the
topography image in nm: minimum coordinate corresponds to the lowest point and maximum
coordinate does to the highest point. Number of height intervals in which the point heights are
counted (i.e. the histogram discretization) can be changed from 3 to 100 in pane Number of bars
below the plot area. Parameter Step is calculated as the image height amplitude divided by the
number of height intervals (number of bars) and corresponds to minimum height interval itself.
Horizontal axis of the histogram shows the occurrence probability (in per cent) for the surface point to
be in given height interval.

Bearing ratio curve shows dependence of the solid material occurrence across the image height.
It is an interpretation of similar surface roughness characteristic however includes not only the rough
layer of the surface but all space described by the SPM image. Vertical axis of the bearing ratio
diagram is calibrated in relative units being fractions of 1, where 1 is height of the highest point in the
image, and 0 corresponds to the lowest point. You can easily compare absolute units in the height
distribution histogram with relative units in bearing ratio plot.

Slide bar between the diagrams visually moves a marker (blue horizontal line) across the image
height. Information about the marker position and corresponding values for the occurrence probability
(Height distribution) and bearing ratio (Bearing ratio) is displayed in digital form below the plots.
Roughness characteristics of surface in the image is also displayed at the bottom of plot area.
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Data plotted in the panel can be saved in file of text format for further analysis. For that,
choose menu command File > Save or button  in the tool bar. Example of the file content is shown
below:

Height analysis of file  for Topography
***********************************
 Height,nm  RH    HD,%    BR,%
***********************************
  -344.85  0.00    0.00  100.00
  -332.57  0.01    0.00  100.00
  -320.30  0.02    0.00   99.99
  -308.03  0.03    0.00   99.99
  -295.75  0.04    0.00   99.99
  -283.48  0.05    0.01   99.99
  -271.20  0.06    0.00   99.98
. . . . . . . . . . . . . . . . . .
Here Height,nm column is absolute values of height, RH is relative height, HD,% column

provides data about height distribution histogram, BR,% column lists data about coordinates of
bearing ratio curve.

Buttons Save Tops and Save Valleys provide ‘cutting and leaving’ of tops above the marker or
valleys below it, correspondingly. The remaining data will be displayed in new 2D visualization
window. Function Save Tops allow to simulate, for example, uniform filling of the relief valleys with
liquid to the level defined by the marker position, function Save Valleys can be interpreted as uniform
cutting of tops down to the height defined by the marker.

3.5 Analysis of local angles

Panel Angular analysis (Fig. 3.5) provides characterization of local angles distribution over the
imaged surface. To open panel, choose menu command View > Angle analysis or press button  in
the tool bar. Estimated are both tilt of every elementary surface site and their orientation on XY plane.
The procedure calculates and analyses normal lines to each elementary site in the AFM-image.

Fig. 3.5. Panel of analysis of local angles distribution.
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Left histogram Tilt shows distribution of angles between vertical axis (Z) and normal lines in
measurement points over all analyzed SPM image. It is a scalar characterization of angles. The slide
bar below the histogram can change range of the tilt angles to be shown in it. Narrowing the tilt angle
range allows to analyze the most meaningful values of the tilt angles. Number of bars in the
histogram (data discretization) can be set in pane Number of bars (4-500). Information about middle
and most frequent angle values is available in lower part of the panel (in left column).

Right polar diagram Orientation characterizes distribution of the normal line projections on
horizontal plane XY. Discretization of the analyzed diagram angles (number of analyzed directions) is
set in pane Number of sectors (8-360). Information about most frequent orientation of the normal line
projection is displayed in lower part of the panel (value Most frequent in right column). Analyzing
orientation diagram, you should keep in mind that homogenous surface relief gives uniformly
distributed orientation diagram. And if there is a preferential direction of the surface features
orientation, the resulted orientation diagram will be elongated in the direction perpendicular to that of
the features (e.g. grains). Example of elongated orientation diagram is shown in Fig. 3.5 and the
analyzed AFM image is presented in Fig. 3.6. Note that the grains in the image are elongated
perpendicular to the long axis of orientation diagram.

Fig. 3.6. Comparison of grain orientation in AFM image and resulting orientation diagram.

The described peculiarity of the orientation diagram is explained by the most frequent change
of the normal line direction along the short axis of features (e.g. grains) forming the heterogenous
surface relief.

Slide bar at right side of the panel allows to shift bottom limit of the analyzed range simulating
cutting the surface image portion below the marker. Both histogram Tilt and diagram Orientation will
analyze angles in the image above the height set by marker. That can be used, for example, for
surface peaks characterization.

3.6 Statistical information panel

Menu command View > Surface Info or button  in the tool bar brings up a specialized panel
displaying information about current (active) image (Fig. 3.7).

Data displayed in the panel can be saved in file of text or bitmap format. For that, choose menu
command File > Save or button  in the tool bar while panel Surface Info is active.
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Fig. 3.7. Panel Surface Info.

3.7 Control panel ‘View layout’

Control panel View layout (Fig. 3.8) serves for tuning the appearance of images in 2D and 3D
visualization windows. The panel is normally visible however if the panel is disabled, it can be brought
up to the desktop by menu command View > View layout or by pressing button  in the tool bar.
The panel can be docked to right border of the program desktop if to drag it to the upper right corner.
It can be also undocked if to drag it taking for title area.

Fig. 3.8. Panel View Layout (tab General).
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3.7.1 Tab General
Tab General (Fig. 3.8) of panel View layout manages sunlight simulation for the active image.

The sunlight simulation is enabled by switch Enable light. Slider bars Polar angle and Tilt angle adjust
corresponding settings for the virtual light source. Drawings above the slider bars visualize the light
source position interactively. You can set these parameters also typing numbers in the panes below
the slider bars. Option Apply automatically enables on-line change of the images while settings are
adjusted. If the option is disabled, the changes made in the tab are applied to the image after
pressing button Apply.

3.7.2 Tab 3D View
Tab 3D View (Fig. 3.9) controls visualization settings for 3D visualization window.

Fig. 3.9. Tab 3D View of View layout panel.

Slider bars Scale XY and Scale Z adjust corresponding scales of image in active 3D visualization
window. Slider bar Distance allows to zoom in or out the image in active 3D visualization window.

In area Skin you can select the contrast image from the current data set (if they are recorded in
the file or linked to current image) that will be used for coloring the 3D topography image. The
resulting image will be obtained by building a 3D topography wireframe and coloring it according to
the data from selected contrast image (Fig. 3.10). If you need to watch pure 3D topography image,
select topography as a skin.

Fig. 3.10. Example of 3D topography image with phase contrast image used as a skin for coloring.
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3.7.3 Tab Palette
Tab Palette (Fig. 3.11) controls coloring of active SPM image. You can separately adjust color

settings for each data type (topography, phase contrast, lateral force map etc.) specifying
corresponding image in the selector in upper part of the tab. Adjusting settings, you can watch
corresponding changes in image on-line.

Data type
selector

Markers

Height scale

Height
distribution
curve

Color at
the active
marker
position

RGB
parameters
of active
marker

Position of
active
marker

Color
channels
intensity
lines

A node

Limits
shifting

Buttons for
marker
switching
on/off

Fig. 3.11. Tab Palette of View layout panel and its elements.

Main function of the tab is adjustment of custom settings for the visualized image coloring. The
control elements described in Fig. 3.11 allow to do that in several ways. First of all you can shift the
color palette limits to emphasize meaningful range of the image heights. Height distribution curve
helps to do that showing the most meaningful range of heights. So, you need to move the top and
bottom markers with mouse to the positions where the height distribution curve starts to exceed
noticeably zero line. Button Cut 5% allows to do that automatically shifting the color range limits to
the distribution curve positions where it makes 5 per cent of its maximum rise. Position of active
marker is displayed in pane Height and it can be parametrically changed by typing necessary number
in the pane.

To adjust color of image at the marker position, make corresponding marker active by clicking
with mouse on it (activated marker itself will then change color from white to red) and then assign
custom color for it. Marker color can be changed in following ways:

1. Adjust colors with channel intensity lines shifting nodes opposite to the marker. There are
three color channels controlling the resulting color of the image at the height marked with
the marker: red (R), green (G) and blue (B). The channel intensity can vary from 0 to 255
and corresponds to general color model accepted in Windows-based systems.

2. Parametrically assign intensity for the color RGB channels in corresponding panes R, G and
B.

3. Double click on example of color at the active marker position and select color in new panel
of color (Fig. 3.12) (it is common panel for color adjusting in Windows).
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Fig. 3.12. Panel for adjusting custom color.

If you need more than two markers (and correspondingly colors) to color the height range of
the SPM image, add new markers to the height scale either by pressing button New marker or simply
clicking with left mouse button from right side of the height scale. Then you can adjust the new
marker position with mouse and assign custom color for the marked height as described above. To
delete any of newly added markers, activate it and press button Delete marker or simply click on it
with right mouse button.

3.7.4 Tab Colors
Tab Colors (Fig. 3.13) allows to change colors of following elements of the visualization

windows:
2D background – background color of 2D visualization window. Default color is white.
3D background – background color of 3D visualization window. Default color is white.
Grid – color of gridlines used to form 3D SPM image when corresponding option is set in tab

Show.
Lateral face – color of lateral faces in 3D image when corresponding option is set in tab Show.
Axis – color of axes lines and markers in the 3D visualization window when corresponding

option is set in tab Show.
Info text – font of text displaying auxiliary information in the 3D visualization window.

Fig. 3.13. Tab Colors of View layout panel.
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Necessary changes can be made in additional panels (common for Windows) brought up by
pressing buttons opposite the options titles or by double clicking on example of currently set color.

3.7.5 Tab Show
Tab Show (Fig. 3.14) sets following options for 3D visualization of SPM image. Section State:

defines rendering parameters for the SPM image while it is stationary (not moved with mouse).
Section Move: defines rendering parameters for the SPM image during its movement with mouse.
Selector type draw sets mode of rendering the surface topography in 3D image:

• Points – the surface is rendered by dots placed in measuring points at the height defined by
Z scale.

• Lines on X – the surface is rendered as a series of lines stretched along X direction of the
image and tracing corresponding surface profiles. I.e. the image is build of lines oriented
along X direction and linking all measurement points located on the same line.

• Lines on Y – the surface is rendered as a series of lines stretched along Y direction of the
image and tracing corresponding surface profiles. I.e. the image is build of lines oriented
along Y direction and linking all measurement points located on the same line.

• Grid – the surface is rendered with mesh. It can be interpreted as a mix of lines on X and
lines on Y options.

• Color grid – the surface is rendered with mesh and additionally colored according to the
height scale in tab Palette.

• Polygon – the surface is rendered by polygons and colored according to the height scale in
tab Palette.

Fig. 3.14. Tab Show of View layout panel.

Selector step defines distance between adjacent nodes for image rendering expressed in points
of the image matrix. For example, step 5 means that only every fifth point of the image matrix will be
processed for rendering. Step 1 means that every point of the image matrix will be processed during
rendering, i.e. the picture will most precisely visualize obtained data. Greater step number allows to
unload the system during non-critical operations like the 3D image rotation.

Option Draw lateral face simulates filling of space below the 3D surface making it to look like a
piece of solid cut off the bulk sample. The unchecked option will leave the 3D surface to look like a
shell.

Option Draw axis shows/hides XYZ axes in the 3D image.
Draw inside is option filling the surface between the lines and making it opaque (when selector

type draw is set for points, lines, or grid).
Draw info text – shows/hides brief information in upper left corner of 3D visualization window

about the image parameters.
Scroll bar – shows/hides a scroll bar in 3D visualization window.
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3.8 Zooming SPM image

Menu command View > Zoom or selector  in the tool bar allow to magnify active
2D image in the desktop. Available are 100%, 200%, 400% and 800% zoom values. Zoom 100%
returns the image to its original size.

4 Menu Process

Menu Process contains basic functions used for initial processing of SPM images. When you
apply processing functions, a copy of data set is created and the operation is recorded in the list Step
of the status bar (Fig. 1.1). This list allows to return to the necessary step (analogous to undo
function).

4.1 Normalization

Command Process > Normalize shifts zero plane to the lowest point of the processed SPM
image. This function processes only topography image if the file contains a set of data types.

4.2 Arithmetic operations with image matrix

Command Process > Arithmetic brings up dialog window (Fig. 4.1) that allows to perform
simple arithmetic operations (addition, subtraction, multiplication, division) with data matrix.

Fig. 4.1. Dialog window Arithmetic.

The window has two sections to specify objects between which the arithmetic operation will be
executed. First object (section First) can be SPM image matrix only. By default, active SPM file is cited
in the filename pane. If you intend to process other file, use button >> to select different one.

Section Second serves to specify second object. It can be either number or other file that is
selected in switch Number / File. If second object is set to Number, enter necessary number in the
pane with the same name (Number). If second object is set to File, use button >> to select second
SPM data file. Note that SPM image in second file must be of the same size (same number of points in
directions X and Y) as the first one.
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To perform the arithmetic operation between the specified objects, press one of buttons in
lower left corner of the window:  + ,  – ,  × ,  /  for addition, subtraction, multiplication, or division,
correspondingly. Operation of addition and subtraction of a number, correspondingly, add or subtract
this number off Z coordinate of every data point in matrix. Operations of multiplication or division
scale Z coordinate of every data point in the matrix relative by the factor specified in pane Number. If
both objects are files containing a set of data of different type, additional dialog window (Fig. 4.2) will
offer you to select what data type from the sets should be treated with the operation.

Fig. 4.2. Dialog window allowing selection of data type from the sets for arithmetic operation.

The resultant image will be visualized in a new 2D window. If necessary, save it in file on hard
disk using standard procedure (§2.2).

4.3 Cutting a portion out of SPM image

Menu command Process > Cut or button  in the tool bar activate function of cutting a
portion of image off the active SPM matrix. After the activation, additional panel Select (Fig. 4.3)
appears in the program desktop where coordinates (in matrix points) of the selected area are
displayed. You can also use this panel to enter the coordinates manually.

Fig. 4.3. Panel Select displaying coordinates of the selected area for function Cut and initial (left) and resultant (lower right)
SPM images.

Together with appearing of additional panel, a rectangle with inverted borders appears in the
initial SPM image to show interactively the selected area. Its upper left (start) and lower right (end)
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points are emphasized and namely their coordinates are displayed in panel Select. Instead of manual
defining of coordinates for the image portion to be cut out of the initial data matrix, you can change
the selected area size moving the start and end points by mouse with pressed left button (Fig. 4.3).
Also, you can mark the area of interest simply dragging mouse with pressed left button within the
initial image (Fig. 4.3).

After pressing button  OK  in panel Select, a new 2D visualization window with the cropped
image appears in the program desktop (Fig. 4.3). If necessary, you can save the resultant image in
file on hard disk using standard procedure (§2.2).

4.4 Leveling of SPM image

Menu item Process > Flattening contains six functions for active SPM image leveling. They
provide elimination of a common tilt or curvature from the image. General inclination of the sample
surface and spherical character of the scanner movement can cause these distortions. Below, the
functions are described.

Line on X direction – so called 1D leveling. For each scan line along X-axis, an approximating
straight line is calculated and then is subtracted from the initial profile line. This procedure eliminates
tilt of each scan line along X-axis and shifts zero line to the profile midline. This function can be
applied if the image fast scan direction was along X axis.

Line on Y direction – so called 1D leveling. For each scan line along Y-axis, an approximating
straight line is calculated and then is subtracted from the initial profile line. This procedure eliminates
tilt of each scan line along Y-axis and shifts zero line to the profile midline. This function can be
applied if the image fast scan direction was along Y axis.

Plane – so called 2D leveling. The average plane for entire image is calculated and then
eliminated from the initial surface image. This procedure eliminates general tilt of the image and shifts
zero plane to the image middle plane. After the function selection, additional dialog panel (Fig. 4.4) is
activated displaying the calculated factors of the average plane equation. If necessary, you can
change the factors in corresponding panes. Pressing button OK, the procedure is finished and a new
2D visualization window with resulting image appears in the desktop.

Fig. 4.4. Additional dialog panel displaying factors of calculated equation for Plane flattening.

Parabola on X – so called 3D leveling. The average paraboloid surface along X axis for entire
image is calculated and then eliminated from the initial surface image. This procedure eliminates
general curvature of the image along X axis and shifts zero plane to the image middle plane. After the
function selection, additional dialog panel (Fig. 4.5) is activated displaying the calculated factors of
equation for the average paraboloid surface along X axis. If necessary, you can change the factors in
corresponding panes. Pressing button OK, the procedure is finished and a new 2D visualization
window with resulting image appears in the desktop.
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Fig. 4.5. Additional dialog panel displaying factors of calculated equation for Parabola on X flattening.

Parabola on Y – so called 3D leveling. The average paraboloid surface along Y axis for entire
image is calculated and then eliminated from the initial surface image. This procedure eliminates
general curvature of the image along Y axis and shifts zero plane to the image middle plane. After the
function selection, additional dialog panel (Fig. 4.6) is activated displaying the calculated factors of
equation for the average paraboloid surface along Y axis. If necessary, you can change the factors in
corresponding panes. Pressing button OK, the procedure is finished and a new 2D visualization
window with resulting image appears in the desktop.

Fig. 4.6. Additional dialog panel displaying factors of calculated equation for Parabola on Y flattening.

Paraboloid – so called 3D leveling. The average paraboloid surface for entire image is calculated
and then eliminated from the initial surface image. This procedure eliminates general curvature of
whole image and shifts zero plane to the image middle plane. After the function selection, additional
dialog panel (Fig. 4.7) is activated displaying the calculated factors of equation for the average
paraboloid surface. If necessary, you can change the factors in corresponding panes. Pressing button
OK, the procedure is finished and a new 2D visualization window with resulting image appears in the
desktop.

Fig. 4.7. Additional dialog panel displaying factors of calculated equation for Paraboloid flattening.



SurfaceView: Manual

24

Flattening procedure is recommended to perform for all images unprocessed before. The most
common used are Plane and Paraboloid flattening. In any case, you can try all the flattening functions
estimating the results and choosing that one that ensures absence of processing artifacts in the
image. If necessary, you can save the resulting image in file on hard disk using standard procedure
(§2.2).

5 Menu Functions

Menu Functions contains commands included into the software as plug-ins. The plug-in modules
can be developed separately from the SurfaceView core. They are linked to the program during its
start. To include the plug-in module into the program, it should be described in corresponding *.inf-
file. Both plug-in modules and their *.inf-files should be placed in subfolder Plugins of the
SurfaceView folder.

5.1 Export to text format

The function is realized by plug-in module SaveTXT.dll. The function saves the image data
into file of text format. The target file name should be entered manually. The data are recorded line
by line as in example below:

*****************************************************
      x, nm |      y, nm |      z, nm
*****************************************************
      0.000 |      0.000 |     41.504     [First line start]
     87.835 |      0.000 |     50.659
    175.670 |      0.000 |     48.828
    263.505 |      0.000 |     41.504
    351.340 |      0.000 |     34.180
    439.174 |      0.000 |     27.466
       ...  |       ...  |       ...
  19587.183 |      0.000 |   -133.667
  19675.018 |      0.000 |   -136.108
  19762.852 |      0.000 |   -145.264
  19850.687 |      0.000 |   -156.250
      0.000 |     87.835 |     46.997     [Second line start]
     87.835 |     87.835 |     56.152
    175.670 |     87.835 |     57.373
    263.505 |     87.835 |     45.776
    351.340 |     87.835 |     30.518
    439.174 |     87.835 |     10.986
       ...  |       ...  |       ...

Exported data can be then used for successive processing and analysis in other software.
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5.2 Filters

The group of functions is realized by plug-in module Filter.dll and has two types of filters:
Pulse filter and Medium filter.

5.2.1 Pulse filter
Dialog window for entering the filter parameters is shown in Fig. 5.1.

Fig. 5.1. Dialog window for entering Pulse filter parameters.

Input data are:
X – the filter size on X axis;
Y – he filter size on Y axis.
Threshold fault – this parameter is used for checking the difference between initial and resulting

height of a matrix point. If the difference is lower or equals to the threshold fault, initial value of the
point height will be accepted instead of resulting one. Recommended value is 0.

Number significant counting out – number of significant counts in sample. It allows neglect too
high and too low points accidentally appearing in the sample. Recommended is value (X * Y – 2).

5.2.2 Medium filter
Dialog window for entering the filter parameters is shown in Fig. 5.2.

Fig. 5.2. Dialog window for entering Medium filter parameters.

Input data are:
X – the filter size on X axis;
Y – he filter size on Y axis.
Threshold fault – this parameter is used for checking the difference between initial and resulting

height of a matrix point. If the difference is lower or equals to the threshold fault, initial value of the
point height will be accepted instead of resulting one. Recommended value is 0.
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5.3 Noise

This group is realized by plug-in module Noise.dll and includes three functions: Tip
estimate, Erosion and Dilation. This group of functions processes errors brought to SPM image by
non-ideal shape of scanning tip.

5.3.1 Tip estimate
Function Tip estimate calculates shape of the probe tip. Based on current topography SPM

image, the worst of probable probe tip shapes is reconstructed. Input parameters are sizes of matrix
on X and Y for the reconstructed tip image. Dialog window for entering the function parameters is
shown in Fig. 5.3.

Fig. 5.3. Dialog window for entering parameters to calculate tip shape.

Results of the reconstruction will be displayed as image of the calculated probe tip that was
used for the initial SPM image measurement. The resulting image of probe tip will be displayed in new
2D visualization window. Example of tip estimation based on topography image is shown in Fig. 5.4.

Fig. 5.4. Initial topography image (left) and reconstructed probe tip shape in new visualization window (right).

5.3.2 Erosion
Function Erosion ‘subtracts’ the tip shape from the surface topography image (performs

‘erosion’ of the image). That allows to eliminate errors in the topography measurement caused by
finite curvature radius of the probe tip. To execute this function, get preliminary the probe tip shape
using, for example, function Tip estimate. Example of topography image erosion by reconstructed tip
shape is shown in Fig. 5.5.
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Fig. 5.5. Initial topography image (left), reconstructed probe tip shape (middle) and initial image after the erosion by
reconstructed probe tip (right).

5.3.3 Dilation
Function Dilation ‘add the tip shape to the surface topography image (performs ‘widening’ of

the image). To execute dilation, get preliminary the probe tip shape using function Tip estimate.

5.4 Eliminate phase artifacts

Function Eliminate phase artifacts is realized by plug-in module Elphase.dll. This function
allows to eliminate errors in height measurement from the topography image obtained under tapping
mode. The errors results from heterogeneity of surface material. To execute this function, phase
contrast image should be linked to the topography. After the function start, dialog window appears
where you need to define manually some parameters necessary for the calculations (Fig. 5.6).

Fig. 5.6. Dialog window for definition of parameters necessary for elimination of phase artifacts from topography.

The procedure includes pointing of characteristic points in the phase contrast image shown in
upper left portion of the window and assignment of Young’s modulus for them. To point the
characteristic points, click on them with mouse. Characteristic points should belong to explicit areas in
the image differing with their color (gray scale grade). For example, there are three grades of gray
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scale in Fig. 5.6: black, gray and white. Correspondingly, characteristic points are marked in these
sites.

After pointing out every characteristic point, you should enter its Young’s modulus (stiffness) in
table in upper right portion of the window. To do that correctly, you need to know what materials
make the characteristic areas in the image. After the definition of all characteristic points, you can edit
their parameters (coordinates and Young’s modulus value) in the table.

Then you need to enter other input parameters:
• DYNAMIC / STATIC – measurement mode; phase imaging is performed under dynamic

mode;
• Spring constant  – spring constant of the cantilever (N/m);
• Free amplitude – amplitude of the cantilever free oscillations (nm) for dynamic mode;
• Set point parameter – ratio between working amplitude and amplitude of the cantilever free

oscillations that is supported by the measurement system at constant level;
• Radius of tip curvature – this parameter (in nm) can be taken from the tip characteristic or

measured by SEM or other AFM;
• Basic Young’ s modulus – Young’s modulus of the most spread characteristic area. Usually it

is of middle grade in the gray scale.
After the enter of all parameters, press button OK to execute calculations. The results of

calculation will be displayed in two images: corrected topography image and map of errors at the
topography measurement (Fig. 5.7). The lighter grade in the error map, the greater error was
detected in given point.

Fig. 5.7. 2D visualization window for map of errors in the topography measurement calculated at elimination of phase artifacts.

5.5 Surface tomography

Function Surface tompgraphy is realized by plug-in module Tomography.dll. This is a
specialized function allowing analysis and convenient visualiztion of multilayer SPM images. After the
function start, you will be prompted to enter number of imaged layers (Fig. 5.8). The layers should be
taken in the same area of sample surface and differed with set-point parameter.

Fig. 5.8. A prompt window for entering number of imaged layers before loading surface tomography data.
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After pressing button Next in the prompt window, a specialized dialog window for loading a set
of SPM images will appear in the desktop (Fig. 5.9). You are to load all the imaged layers one by one
taking into account that layer 1 corresponds to upper image, i.e. image measured at the biggest set-
point parameter Rsp. Then the layer images should be loaded at the order of their set-point parameter
decrease. So, first layer should be the image taken at the biggest Rsp, last layer should be the image
taken with lowest Rsp.

Fig. 5.9. A specialized dialog window before (upper) and after (lower) loading of a set of SPM images for surface tomography
analysis.

To simplify the loading process of layer images, you can load a file list. Example of the list of
layer images is below:

32.spm 1.0
33.spm 0.9
34.spm 0.8
35.spm 0.67
36.spm 0.44
37.spm 0.27
38.spm 0.23
39.spm 0.16
41.spm 0.11

The list of layer images files is a file of text format containing only information about the file names
and corresponding values of Rsp after a space. The layers are listed starting from the highest (first)
one and ending with the lowest (last).

After pressing button Next in the loading dialog window, new panel (Fig. 5.10) will offer to
specify some parameters and way of combination of the layer structures.
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Fig. 5.10. Panel for specifying way of combination of the layer structures.

Option No cross is set if the structure layers are to be combined without their crossing. It is the
most probable case. However, if the layers were imaged at different scanning parameters (excepting
Rsp) caused data shift along Z axis (in absolute values) but without change of the image itself, the
layers may cross each other.

If the layers were imaged with the same scanning parameters, you can sort these layers on the
less deformable point in the image (option Deformable point). This point is highlighted with a red
cross in the image. In thi scase you need to enter Young’s modulus for material in the highlighted
point, spring constant of probe cantilever, amplitude of the cantilever free oscillations, probe tip
curvature radius. After pressing button Next in the panel, a specialized visualization window (Fig.
5.11) will appear in the desktop.

Fig. 5.11. A specialized window for visualization of the surface tomography data: mode of layer viewing (left) and mode of
horizontal section visualization (right).

Specialized visualization window contains three areas:
2D image area – an image in upper left portion of the panel. It shows 2D image of current

layer. Selector 2D View for sets one of two visualization modes: Layer and Horizontal section. Mode
Layer provides visualization of fixed SPM images of layers while mode Horizontal section allows to
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visualize the layers at arbitrary vertical level. 2D image of the panel also contains a line that sets a
cross section visualized in other areas of the panel.

Phase cross section – an image in lower left portion of the panel. It visualizes cross section of
all the phase contrast images on the line marked in 2D image area. Phase cross section shows
distribution of material stiffness under the surface that can be interpreted as structures hidden under
the surface. Note that the technique allows to uncover hard material inclusions hidden under layers of
soft material (e.g. hard grains in soft matrix). However, you can’t watch soft inclusions under layer or
area of hard material.

Topography cross section – a plot in right portion of the panel displaying cross sections of all
topography images along the line marked in 2D image. Slider bar at right side of the plot allows to set
active layer (in Layer visualization mode) or to select arbitrary level on vertical axis (in Horizontal
section mode) for displaying in 2D image area. Active layer profile line is displayed by bold line.
Current level on vertical axis is shown by blue horizontal line opposite the slider.

5.6 Contact deformation

Function Contact deformation is realized by plug-in module Deform.dll. This is a specialized
function allowing to simulate and analyze contact interaction of two surface sites represented by SPM
images.

After the function start, a specialized dialog window for loading SPM images of two surfaces
subjected to the simulation will appear in the desktop (Fig. 5.12). Note that the loaded SPM images
should contain both topography and phase contrast images in their data sets. Besides, bothSPM
images must be of the same size (in points and in nm).

Fig. 5.12. A specialized dialog window after loading of two SPM images for contact deformation simulation and analysis.

After loading images and pressing button Next, new panel Set elastic values for surface appears
where you need to define manually some parameters necessary for the calculations (Fig. 5.13). The
procedure includes pointing of characteristic points in the phase contrast image shown in upper
portion of the panel and assignment of Young’s modulus for them. To point the characteristic points,
click on them with mouse. Characteristic points should belong to explicit areas in the image differing
with their color (gray scale grade).
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Fig. 5.13. Panel for definition characteristic points on the surface site and assignment of Young’s modulus for them.

After pointing out every characteristic point (Fig. 5.13), you should enter its Young’s modulus
(stiffness) in table in lower portion of the panel. To do that correctly, you need to know what
materials make the characteristic areas in the image. After the definition of all characteristic points,
you can edit their parameters (coordinates and Young’s modulus value) in the table. After pressing
button Next in the panel, a specialized visualization window (Fig. 5.14) will appear in the desktop to
display calculated equivalent images of topography and elasticity.

Fig. 5.14. Specialized visualization window of Contact deformation function showing equivalent images of topography (left
image) and elasticity (right image).

The equivalent topography image is built by adding the two rough layers together. Map of
equivalent elasticity is calculated based on data from phase contrast images and proportionally takes
into account depth of the material in rough layer for every image matrix point. The contact interaction
is simulated by pressing a non-deformable plane into the equivalent surface.

After pressing button Finish in the window, a specialized analysis panel Heights (Fig. 5.15–5.17)
will be finally brought up. The specialized panel has three tabs where the calculated data are analyzed
in three different ways.

First tab Manual (Fig. 5.15) shows Height distribution histogram and plots Height bearing ratio.
Using slider in the middle of panel, you can manually set level (depth) of the two surface approaching
at simulation of their contact interaction. Info line will interactively display corresponding real contact
area (RCA, parameter Area) in square microns, relative area (in per cent) and load in micronewtons.
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Fig. 5.15. A specialized panel for analysis of simulated contact interaction of two surfaces using function Contact deformation
(tab Manual).

Switch Show contact area at the window bottom brings up additional visualization window
displaying map of real contact area of the two surfaces corresponding to the set approach level. In
the additional window Show contact, black color shows areas of contact and white color shows non-

interacting areas of the surfaces. Button  saves the plotted data in a file on hard disk.
Tab Area, Load (Fig. 5.16) displays dependencies of RCA (Area, square microns) and contact

load (Load, micronewtons) on the approach level of the two surfaces. Slider below the plot area sets
necessary approach level similar to the slider in tab Manual.

Tab Area(Load) (Fig. 5.17) plots real contact area as function of contact load for the simulated
contact of the two surfaces.
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Fig. 5.16. A specialized panel for analysis of simulated contact interaction of two surfaces using function Contact deformation
(tab Area, Load) and additional window for visualization of contact area.

Fig. 5.17. A specialized panel for analysis of simulated contact interaction of two surfaces using function Contact deformation
(tab Area(Load)) showing dependence of RCA on contact load.
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6 Menu Windows

Menu Windows contains commands for managing visualization windows within the SurfaceView
desktop. The commands are common for the Windows based systems. Below the commands, open
visualization windows are listed. This lower section of the menu can be used for fast switching
between the windows.

Note that all data in open visualization windows are swapped in temporary files on hard disk.
Closing the windows by control buttons in their title bars just unloads the data from RAM, not from
the temporary files. Therefore, if you need to return the closed data back to the desktop, you can do
it quickly by choosing the file name in selector File or corresponding step description in selector Step
in the SurfaceView status bar. To unload the data from program completely (including the swap files
deleting), use buttons Close near selectors in the status bar.
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